not-front-rule

My wipers don't work!

Welcome to the Mercedes-Benz Club of America Forums
Here, you'll find members en masse who can talk, guide, answer or listen to your Mercedes-Benz related questions and comments. Participation in the forums is free to Club members. If you're a guest of this site, you'll have access to our read-only discussions. Like what you see? Join the Club to get full Q&A privileges. If this is your first visit, be sure to check out our FAQ page.  To start viewing messages, select the forum that you want to visit from the selection below.

Forum Jump

9 replies [Last post]
Member
scoot's picture
Altadena, CA
Offline
Joined: May 9th, 2008

Posts:
520

Vehicles
1967 250SL
1967 250S

I've had my 71 250 C for a few months now and we've been getting along just fine. One day I pressed the foot pump for the washer and of course it did not work, but it did turn on the wipers momentarily which surprised me. OK, so that's clever. But the problem is that now the wipers don't work. I can press the washer pedal - nothing, I can use the switch on the turn signal - nothing. I checked the fuse and it is fine. Does this ring any bells for anyone? Thanks, Scott.

Share this
Guest
79Mercy's picture
Offline

Posts:
80
Re: My wipers don't work!

Replace the fuse or atleast clean the connections, I had the same issue with my eletric sunroof, I cleanned the connections on the fuse terminal and the sunroof worked again.

__________________

1979 280CE 219,200 miles

1976 300D 193,500 miles

Guest
MBman's picture
Offline

Posts:
397
Re: My wipers don't work!

dont assume the fuse is good, check for 12 V across the connections with wiper on, if you have 12v , then look to the combination switch , if 12 V there , then look to motor. Really just have to eliminate electrical issues in a logical fashion

Member
scoot's picture
Altadena, CA
Offline
Joined: May 9th, 2008

Posts:
520

Vehicles
1967 250SL
1967 250S
Re: My wipers don't work!

Is there also a relay in the middle of all this?

Guest
MBman's picture
Offline

Posts:
397
Re: My wipers don't work!

not that I am aware of

Member
scoot's picture
Altadena, CA
Offline
Joined: May 9th, 2008

Posts:
520

Vehicles
1967 250SL
1967 250S
Re: My wipers don't work!

So now my wipers do one wipe if I press the foot pump for the washer, but nothing for the wiper switch. Gremlins....

Member
redghost's picture
Seattle, WA
Offline
Joined: December 17th, 2001

Posts:
1150

Vehicles
2002 S430
1995 300D
1974 450SL
1972 220D
Re: My wipers don't work!

The frog making the wiper function tells me you have good contact for function. The combo switch is dead. It could need you to check for poor contact in the stalk, or just get a fresh one, since I have yet to find a way to rebuild one

__________________

clay

2002 S430 - Victor, White Tie & Tails
1974 450SL Frosch, my little froggy prince, after meeting a bunch of toads
1972 220D - Gump - She was green, simple and ran and ran
1995 E300D - Cleo - Killed by a Suzuki Vitara
POS 1987 SDL - Beware Nigerian Scammers

Member
scoot's picture
Altadena, CA
Offline
Joined: May 9th, 2008

Posts:
520

Vehicles
1967 250SL
1967 250S
Re: My wipers don't work!

redghost;176295 wrote:
The frog making the wiper function tells me you have good contact for function. The combo switch is dead. It could need you to check for poor contact in the stalk, or just get a fresh one, since I have yet to find a way to rebuild one
I have a replacement (untested) combo switch that I got from the junkyard (hope it works) because one of the little ears that holds the spring for turn signal cancellation was broken on my existing switch. Just haven't gotten to cleaning it and installing it. I hope that it is good! Thanks.

Member
Nigel115's picture
Horsham
Offline
Joined: October 22nd, 2007

Posts:
11

Vehicles
1999 Sprinter
1991 190E
1984 G Wagon
1971 220
Re: My wipers don't work!

Was the automatic park for the wipers working? If it is not then the induced voltage when you turn off the wipers burns out the combination switch fairly quickly. The auto park can often be repaired by cleaning/adjusting the contacts in the wiper motor. (With the motor out)

Hope this is some help

Nigel

__________________

1984 300GD Cabriolet/pick up

Member
scoot's picture
Altadena, CA
Offline
Joined: May 9th, 2008

Posts:
520

Vehicles
1967 250SL
1967 250S
Re: My wipers don't work!

Nigel115;177408 wrote:
Was the automatic park for the wipers working? If it is not then the induced voltage when you turn off the wipers burns out the combination switch fairly quickly. The auto park can often be repaired by cleaning/adjusting the contacts in the wiper motor. (With the motor out)

I don't know. Perhaps the combo switch never worked, I'm not sure I tried it. At present the wipers wipe once when I press on the washer pump, and they stop at the right spot, so I would guess that this means that they are parking correctly. I'll need to unplug the combo switch and try the other combo switch and see if that fixes things. Until then, I can press the washer pump whenever I need a wipe. Not very elegant but...

Forum Jump

Share this