not-front-rule

BAS/ASR Error Messages

Welcome to the Mercedes-Benz Club of America Forums
Here, you'll find members en masse who can talk, guide, answer or listen to your Mercedes-Benz related questions and comments. Participation in the forums is free to Club members. If you're a guest of this site, you'll have access to our read-only discussions. Like what you see? Join the Club to get full Q&A privileges. If this is your first visit, be sure to check out our FAQ page.  To start viewing messages, select the forum that you want to visit from the selection below.

Forum Jump

1 reply [Last post]
Guest
mcguirejw's picture
Offline

Posts:
28

Suddenly my 99 E300 is tossing up an error message that takes over that display space on the dash, saying "B-A-S", and "A-S-R" appears in a little window on the lower left corner. This is the first time I have ever gotten an error message about the braking system in any car, let alone an MB. Of course, the manual says to take it to the dealer, and also that it is OK to drive. Any idea what I am in for??? Could it be a speck of dirt lodged somewhere inconvenient to a sensor of some sort? :confused:

Share this
Member
lkchris's picture
Albuquerque, NM
Offline
Joined: January 29th, 1998

Posts:
3164

Vehicles
2007 GL320 CDI 4MATIC
Re: BAS/ASR Error Messages

Message appears whenever battery is disconnected.

Also can be defective brake light switch.

https://www.mbwholesaleparts.com/StarTuned/pdfs/07MarESP.ST.FSB.pdf

Forum Jump

Share this