not-front-rule

92 500SL need help

Welcome to the Mercedes-Benz Club of America Forums
Here, you'll find members en masse who can talk, guide, answer or listen to your Mercedes-Benz related questions and comments. Participation in the forums is free to Club members. If you're a guest of this site, you'll have access to our read-only discussions. Like what you see? Join the Club to get full Q&A privileges. If this is your first visit, be sure to check out our FAQ page.  To start viewing messages, select the forum that you want to visit from the selection below.

Forum Jump

9 replies [Last post]
Guest
HANIVW's picture
Offline

Posts:
2

Hello guys i have a mercedes benz 92 500sl , i drove the car all summer. it was running fine and every thing works great .......well i parked it for the winter time , and i came back after 2 months , i start the car , its start right up had to jump it thu , runs fine idle fine.... but the cluster guage , like oil pressure , gas guage , rpm , speedometer all of these guages are not working, the only one is working is the temptraure guage i didn't do anything to the car just parked it and thats it , can someone help me tell me what to look for and how to fix it thanks hani

Share this
__________________

treat people with respect and treat them the way u wanna be treated and god bless

Member
jtripp's picture
Babylon, NY
Offline
Joined: September 15th, 1976

Posts:
1289

Vehicles
1996 S420 LWB
1995 S350
Re: 92 500SL need help

Did you accidentally connect the jumper cables to the wrong terminals on the battery?

__________________

New York club member since 1976.

Continuous Mercedes ownership since 1964.

1993 300SD with '99 606 engine. 111,040 miles.
1994 S350   75,238 miles
1995 S350 148,124 miles.
1996 S420 with '99 606 engine  Sold
1999 S600  one of 14 imported  Sold 
1989 Bentley 8  Sold at 40,000 miles.

Guest
HANIVW's picture
Offline

Posts:
2
Re: 92 500SL need help

Hello thanks for the mail no i didnt hook up the wrong post. just jump it and the car start.......thats all butnothing was working onthe dash except clock and temo guage thanks hani very wired

__________________

treat people with respect and treat them the way u wanna be treated and god bless

Member
jtripp's picture
Babylon, NY
Offline
Joined: September 15th, 1976

Posts:
1289

Vehicles
1996 S420 LWB
1995 S350
Re: 92 500SL need help

I have a friend in the club who dealt with the exact same problem on a '92 S class car. The problem was handled offline via PM (Private Message).

I will PM him to see what the outcome was.

__________________

New York club member since 1976.

Continuous Mercedes ownership since 1964.

1993 300SD with '99 606 engine. 111,040 miles.
1994 S350   75,238 miles
1995 S350 148,124 miles.
1996 S420 with '99 606 engine  Sold
1999 S600  one of 14 imported  Sold 
1989 Bentley 8  Sold at 40,000 miles.

Guest
Hunter's picture
Offline

Posts:
2
Re: 92 500SL need help

WOW, I also have an 1992 500SL and have the exact same problem. I did not start it for 2 months and when I went to use it the battery was dead. I charged it and it turns on and runs fine but all the dash gauges don't work. If someone can email a wiring diagram I probally figure it out.

Member
lkchris's picture
Albuquerque, NM
Offline
Joined: January 29th, 1998

Posts:
3164

Vehicles
2007 GL320 CDI 4MATIC
Re: 92 500SL need help

You wouldn't believe the wiring diagram for these cars.

You'll need to use the online connection provided via the service DVD to find one. Even then, good luck.

http://www.startekinfo.com/StarTek/outside/9124/?requestedDocId=9124

Guest
Peter Guenther 1's picture
Offline

Posts:
653
Re: 92 500SL need help

I am a trained electronics tech, and cant interpret their schemantic, they show wiring and then go into a box with a semiconductor symbol, or logic.

Member
jtripp's picture
Babylon, NY
Offline
Joined: September 15th, 1976

Posts:
1289

Vehicles
1996 S420 LWB
1995 S350
Re: 92 500SL need help

Check all of the fuses in the main fuse box for continuity. Also remove the cover from the computer housing on the right fender and check the fuses on the rearmost computer module which is the Base Module.

The wiring diagrams are indeed a nightmare to decipher. They must be printed out trimmed and taped together to be able to match the drawings to the item designations at the bottom.

The wiring diagrams are laid out in a grid pattern. The modules are across the top. The individual electrical consumers are across the bottom and the connections are running along the center of the diagram.

Alldatadiy.com has all the wiring diagrams for your car. They also show all connections, ground points etc. All info obtained from Mercedes at a more reasonable price.

__________________

New York club member since 1976.

Continuous Mercedes ownership since 1964.

1993 300SD with '99 606 engine. 111,040 miles.
1994 S350   75,238 miles
1995 S350 148,124 miles.
1996 S420 with '99 606 engine  Sold
1999 S600  one of 14 imported  Sold 
1989 Bentley 8  Sold at 40,000 miles.

Guest
Hunter's picture
Offline

Posts:
2
Re: 92 500SL need help

jtripp;158503 wrote:
Check all of the fuses in the main fuse box for continuity. Also remove the cover from the computer housing on the right fender and check the fuses on the rearmost computer module which is the Base Module.

The wiring diagrams are indeed a nightmare to decipher. They must be printed out trimmed and taped together to be able to match the drawings to the item designations at the bottom.

The wiring diagrams are laid out in a grid pattern. The modules are across the top. The individual electrical consumers are across the bottom and the connections are running along the center of the diagram.

Alldatadiy.com has all the wiring diagrams for your car. They also show all connections, ground points etc. All info obtained from Mercedes at a more reasonable price.

I checked fuses under hood on driver side fender. Where is the other cover from the computer housing?

Thanks Hunter

Member
jtripp's picture
Babylon, NY
Offline
Joined: September 15th, 1976

Posts:
1289

Vehicles
1996 S420 LWB
1995 S350
Re: 92 500SL need help

The computer housing is on the passenger fender on the 4 door S class cars from '92-'99 that I am familiar with. Due to space limitations Mercedes may have located the housing elsewhere on the 129 chassis.

If no one else answers perhaps you could ask in the SL section of this forum.

__________________

New York club member since 1976.

Continuous Mercedes ownership since 1964.

1993 300SD with '99 606 engine. 111,040 miles.
1994 S350   75,238 miles
1995 S350 148,124 miles.
1996 S420 with '99 606 engine  Sold
1999 S600  one of 14 imported  Sold 
1989 Bentley 8  Sold at 40,000 miles.

Forum Jump

Share this