not-front-rule

1999 E300 Rough idle and black smoke

Welcome to the Mercedes-Benz Club of America Forums
Here, you'll find members en masse who can talk, guide, answer or listen to your Mercedes-Benz related questions and comments. Participation in the forums is free to Club members. If you're a guest of this site, you'll have access to our read-only discussions. Like what you see? Join the Club to get full Q&A privileges. If this is your first visit, be sure to check out our FAQ page.  To start viewing messages, select the forum that you want to visit from the selection below.

Forum Jump

2 replies [Last post]
Former Member
jojocluna's picture
Walnut, CA
Offline
Joined: October 30th, 2009

Posts:
59

Vehicles
None

My 1999 E300 developed a leak at the injector pump (fuel delivery valve). After the mechanic replaced and torx all the delivery valve the car started with a heavy black exhaust smoke. He run the car for 20 minutes or so but the exhaust never cleared.

I check you form and found M Booth direction for the proper installation technic of the delivery valve. The mechanic reseal the delivery valves an follow the procedure. The car finally run without the black smoke but idled really rough.

We bought new o-rings and seal and redo the process. Then the black smoke came back with the check engine light which reads multiple cylinder misfire.

someone, help please.....

Share this
Former Member
jojocluna's picture
Walnut, CA
Offline
Joined: October 30th, 2009

Posts:
59

Vehicles
None

Thank you so much Mr. Booth I will relay that to the mechanic. Any suggestion on the rough idle issue and intermitent fuel cutoff between cylinder 1 to 6.

Thank you again for replying....

Forum Jump

Share this